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Introduction

The client-server concept of networking makes programs more flexible and easier to adapt to
different applications. Take video streaming for example, the source may be a web server or an
IP camera, and the destination may be an IE browser or a player program. Users may consider
the source as the “server” and the destination as the “client”. Both server side and client side

will agree to talk to each other under certain constraints.

Users may setup an ACTi camera and view video streams from various video player software.
In this document, we would like to introduce a few popular programs that can communicate
with ACTi products to provide more variety for users. There is no guarantee from ACTi to
promise that ACTi products are fully compatible with certain third party software. If users have
any software related technical questions, please contact ACTi support from

http://www.acti.com/support/case/index.asp

Protocol introduction

User Datagram Protocol

Many real-time streaming applications utilize the UDP protocol. The reasons are:

1. UDP is a fast transmission protocol and is suitable for conferencing and real-time
applications.
2. A few lost data packets will not hurt the audio/video user experience.

3. UDP can save transmission time without data re-transmission and recovery.

ACTi

Connecting Vision
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However, the drawback of UDP is that this protocol does not guarantee data delivery. Since
there is no traffic control over UDP and the server is not aware of transmission failures, it will
send data without holding back. Some programs will never hold back their transmission rate
which result in traffic congestions or even break down the whole network. Therefore, some
gateways and routers may discard certain UDP-based application packets to prevent against

network breakdown.

Transmission Control Protocol

Compared to UDP streaming, TCP streaming is more reliable, and self-constrained. In a local
area network, TCP streaming is fast enough for video live viewing without noticeable latency.
The performance may vary with network conditions when viewing TCP streaming over the
internet. ACTi products support TCP streaming, and we suggest our users to use TCP as the

default protocol.

Real time Transport Protocol & Real time Streaming Protocol

Currently, one of the most common UDP-based applications is RTP streaming. ACTi products
support RTP streaming (RTP over UDP) as well as RTSP over HTTP (RTP over TCP) which is
meant to go through routers without being filtered out. RTSP/HTTP is a standard method of
reliable streaming which makes use of HTTP connections [RFC 2326]. So web clients
(browsers or programs) complying with this protocol can build up connections with
RTSP/HTTP-supported servers without further implementation. However, RTP over TCP may
have variable implementations which MUST be deployed at both server side and client side
[RFC 4571]. Currently, ACTi products do not support any non-standardized RTP/TCP

applications.

Video streaming and encoding schemes

ACTIi has two popular series of IP cameras ACM-series and TCM-series. The ways of directing
streams between the two platforms are slightly different. In this document, users can refer to
the following chapters for more information. Here, we would like to talk about the relation of

video streaming and encoding schemes.

IP devices provide flexibility of video viewing for users to fulfill their requirement. Different
applications may demand for different levels of data transmission and reliability. ACTi products
comply with standard OSI model to implement the following protocols: TCP, UDP, RTP, and

multicast.

ACM-series provides two types of codec—MPEG4-SP, and MJPEG; while TCM-series
provides three—H.264, MPEG4-SP, and MJPEG. Regarding different encoding schemes at
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the server-side, the client-side MUST implement the same type of decoding schemes.

Otherwise, the video data cannot be decoded and displayed.

Since networking protocols are for communications between servers and clients, and video
encoding schemes are for image display, combinations of streaming protocols and encoding
schemes are available. Users only need to make sure that third-party software supports these
standard protocols, and encoding schemes as well, and then they can integrate video streams

with their applications.
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How to stream RTP?

Web Configurator setup (Camera)

Please go to Setup-> Video Setting-> Streaming Method-> select RTP Over UDP.
Please enable “RTSP Authen Enable”

P d | AcTi

>> Video Display
>> Host Setting
>= WAN Setting
>> Date Setting

>! Video Setting
>> Video Adjustment
== Camera Setup
>> Event

>> User Account
== System Info
>> Firmware

>> Profile

=> Factory Default
=> Save Reboot

=> Logout

Configurator

Version V2.0 - Video Setting

Camera Name Camera-1
Streaming Method RTP OverUDP =
RTSP Authen Enable
B2 Frame Enable []
Audioln  Disabled ~
Analog Video NTSC
Resolution 640%480 +

Frame Rate Mode Constant -

Frame Rate 30 -
Encoder Type m
Video Birate Mode  Constant Bit Rate +
Video Maximum Bitrate  UNLIMITED ~
Bitrate 12M ~
RTSPPoit 7070
Video Control Port 6001

Web Configurator setup (Video Server)

Step 1: TCP-v2.0-compliant firmware versions.

Please upgrade your device firmware to version v2.0X or later.

>> Video Display
>> Host Setting
>> WAN Setting
>> Date Setting
>> Video Setting
>> Video Adjust
>> User Account
>> System Info
>> Hrmware

>> Factory Default
>> Save Reboot

>> Logout

A1D-P2N-V2.02.05-AC

1855 = g
Production ID = SED2400-051-1-00041
Factory Default Type = NTSC, Composite, Two Ways Audio (0x71)

WAN Status :

IP Address : 10.0.0.1

Netmask : 255.255.255.0

Gateway

DNS Server .

DDNS Host :

[WAN Connect Status : Disconnect
DNS Connect Status : Disconnect
DONS Connect Status : Disconnect

Svstem Lou:

IMPORTANT: Please notice that for firmware versions v 2.04 or later, RTSP will need

account & password authentication.
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Step 2: Select a

streaming type »> Widoo Display

Please go to Setup-> o sea
*> Wk Selting
Video Setting-> »> Date Setting
. == Video Seiting
select Version 2.0 S
¥ User Account
*» Sysiom indo
*x el e
»> Faciony Defad
»> Sl Rishool

¥ Liosgoud

Srpaming Typal | Wersion Va0 = )

Cesly| [ |

Choose RTP over

UDP >> Voo Display
»> Host Sefting
>> WAN Setting
>> Date Sefting
>> Video Setting
>> Video Adpust
>> User Account
>> Systom ifo

>> Frmware

>> Factory Defoult

>> Save Reboot

5> Logout

Web Configurator setup (Video Decoder)

Please go to Connection
Setting->select “Connect Type” as
RTP

Please switch on “Enable Control

Data” to signal PTZ positioning.

Video Setting
Camera Name ICnmwN

Streaming Metnod | | RTP Over VOP &
TCP Ondy

Audio |l mytticast Onty
TCP & Multicast

Muiticast ®

Analog Video |NTSC ¥
Resolution [N720:480 ¥]
Bitate [T 2mops %]
Frame Rate Mode [Constant 2]
Frame Rate m
Serial Port Bavd Rate [3600 )

o0 Connection Setting

Source Type | Video Server

Connect Type

WVariable FPS | Jse Server's Setting vl

TCP ConnectIP |172.16.52.134 |

Multicast Connect P 228 |,

s s b |

(224.31.0 ~ 239.255.255.255)

Connect User Name | Admin |

Connect Password |uuu |

Enable An STREAM | On v

Enahle Control Data | On w ‘

Dwvell Time

Stream Port (6002

Control Port [B001

Multicast Port |5000

RTF Port (7070

HTTF Port

L

[Apply] [Reset ] m



Web Configurator setup (Camera TCM-series)
Please go to Setup -> Network -> and Port Mapping then enter 7070 in the RTSP Server port
bubble.

Port Mapping

HTTP Port 30
HTTPS Port 48
Search Server Port1 €005
Search Server Port2 5003
Control Server Port 6001

Streaming Server Port  S002

Multicast Server Port for Mediat 5000

Multicast Server Port for Medis? 5001

RTSP Server Port 7070

RTP Multicast Video Fort for Medial 510

RTP Multicast Audio Port for Mediat 5102

RTP Multicast Video Fort for Media2 5104

RTP Muilticast Audio Port for Media2 5105
Multicast

Setting

Multicast IP 228 . 5 .6 .1
[ 224.5.0.1 ~ 239.255.255.255 ]

Multicast TTL 16 [1-255]

IGMP  Disanie v

Step 2:

Please go to Setup -> Video and Audio -> and Basic then “Disable” RTP B2 Frame.

Max Stream Time 0 seconds

0~86400 Secs
0=No time limitation for streaming

RTSP Authen Enable  Enable v

RTP B2 Frame Enable  Disable v
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A Quick VLC configuration to start RTP streaming

Go to Media-> Open Network Stream (Ctrl + N)-> enter URL and “Play”

. VLC media plas

| B [ pis | %° Network |E5f Copture Deviee |

Playback Audio Video Tools View Help Hotwork Protonel
e Cut+0 r % ‘1‘:;;;11@.123456@101.1.41 070 P;’; :
Advanced Open File... Ctrl+Shift+O

Open Folder... Ctrl+F
Open Disc... Ctrl+D
Open Network Stream.... Ctrl+N

Open Capture Device... Ctrl+C

Open Location from clipboard Ctrl+V
Recent Media

Services Discovery
Save Playlist to File... Ctrl+Y

Convert / Save... Ctrl+R
Streaming... Ctrl+S

Quit Ctrl+Q

V] Show more options
Caching 80 ms | Start Time  0.0s %
Flay another media synchronously (extra andio file, ...)

MRL tspi/fadmin:123456@10.1.1.41.7070
EditOptions  xtsp-caching=20

E By Tl

VLC configuration to mount RTP over TCP
If users would like to get video streams over WAN, they may make use of RTSP/TCP to go
through Firewalls or routers without being blocked out. Please keep in mind that ACTi device

streaming type should be set to RTP over UDP.

IMPORTANT: Please make sure that your device supports RTSP/HTTP. Users are

welcome to download ACTi user manuals or release notes on the website.

Please go to Tools-> Preferences

Media Playback Audio View Help
Effects and Filters Ctrl+E

— Track Synchronization
Nz oCREE *’

Media Information Ctrl+1

Codec Information Ctrl+)
Bookmarks Ctrl+B
VLM Configuration Ctrl +W
Messages Ctrl+M

Plugins and extensions

Preferences
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Please select “Show settings”->
All

Select Input/Codecs-> Demuxers
-> RTP/RTSP-> Use RTP over
RTSP (TCP)

To start streaming, please go to

Media-> Open Network Stream

= Preferences

Y
é
Language
| Lifostiay Intertace Type
g -
Audin
A
; © Skins
Tidso
" Skin fls
-
’ Tnstances

[T] Allow only one instance

' File associstions:

Privacy { Network Intersotion

Album et dovaloed policy

4 Activate update notifier
o - Save recently played items
; -
Hotkeys

Show ssttings

Interface Settings

Auto -

T & VIO default fatecfare, with 2 aative fook and feel

Display mode Clessic ook =
Exmbed video i interface

Show a controller in fullsereen

Resize interface to video size
Systray ioon

This &5 VLC's skianable fnterface, You can downivad otter skins at YLO
L .

Browse,

[T Engusus files when in one instence mode

Mannal download anly ~|

Tdays [

Filter

> B Advanced o
. £ Audio
4 | Input/ Codecs
——— Use RIE over RTSE (ICP)
. Audio codecs g
B rv— 7] Fotce multicast RTP vis RTSP
o 7] Twmmel RTSP snd RTE over HITF
adorma |[F| HITE el ot
ov Caching vale {is)
B [7] Kasemna RTSE dislsct
H264 RTEP user name
Lua vt RTSP password
MIPEG
MOD
MPEG-4V
MPEG-TS
Matroska
Ps
Playlist
RTP
RTP/RTSP | _
Shaw sitings
o Simple @ Al

2 e . ==
RTP/RTSP/SDP demuxer (using Live555)

1200 |5

Playback Audio
Open File...
Advanced Open File...
Open Folder...

O0 B

Open Disc...

Open Metwork Stream...

3

Open Capture Device...

Open Location from clipboard

Recent Media

Services Discovery
Save Playlist to File...

Conwvert / Save__

Streaming...

Quit

V. C media playe [ ——c—)

Video Tools View Help
Ctrl+0O
Ctrl+Shift+0
Ctrl+F

Ctrl+D

Ctrl+MN

Ctrl+C

Ctrl+W

Ctrl+Y

Ctrl+R
Ctrl+5

Ctrl+0Q
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Now, it is time to get a video stream! Please paste this URL command into the Address Bar.

http://ip:port/cgi-bin/cmd/encoder?GET STREAM

Remember to change the ip / port to your actual numbers, an example of which would be :

http://192.168.0.100:80/cgi-bin/cmd/encoder?GET_STREAM

Please click on “Show more

options”-> Caching-> set 80ms.
Video latency of RTP/RTSP will
be minimized without sacrificing

video quality.

When you click on “Play”,

prompt will let you log into your

device.

. Open Mediz

Hetwork Protocal

FProtocol Address

HITF | hitpif10.1.1 44/cgi-binfemd fencoder?3ET_STREAM

Bhow more options
Caching 80 ms (= Start Time 0.0z 5

[ Play another media symchronously (extra audio file, ...}

MEL hitp:/10.1.1 44/c gi-binemdencoder¥¥ET_STREAM

Edit Options  file-caching=00

Pleass enter a valid login name and a password for realm Hitpd +1.0 05may2008.

User name  adinin

Pazzword @GBS
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http://ip:port/cgi-bin/cmd/encoder?GET_STREAM

Viewing streaming!!

Media Playback Audio Video

=T

=

http://10.1.1.44/cgi-binfcmd/encoder,

Tools  View Help

> * Advanced
> J Audio
4 [/ Input / Codecs
> Access module
> Audio codecs
4 Demuxers
AT
Avformat
Dv
Dump
H264
Lua Art
MIPEG

MOD
MPEG-4 W
MPEG-TS
Matroska
3

Playlist
RTP
RTP/RTSP

Show settings
() Simple @ Al

RTP/RTSP/SDP demuxer (using Live555)

Tse RTP over RTRF (TCP)

Client port

[ Force multicast RTP vis RTSF

[ Tunnel ETSF and RTF over HTTF
HTTP tunnel port

Caching valve (ms)

[ Kasnna RTSF dialect

RTEP user name

RTEP passwond

Reset Preferences

10
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VLC configuration to start RTSP streaming

Please go to Media -> Open Network Stream and you will find options as shown below: please

select RTSP from list of selections in Protocol and enter your IP/port with connection

commands shown below: in this example “multicast”.

Note: you can also configure more options by clicking on “Show more options” check box, for
settings please refer to “VLC configuration to mount RTP over TCP section”.

i A Open Media M
!i!Network Captu:re Device

Network Protocol

Protocol Address Port
RISP = | 192.168.0.100:7070/multicast 1]

[ Show more options

B =

RTSP Connection Command : Server's Response
rtsp://DevicelP:RispPort |
Irtso://DevicelP:RispPort/udo ‘describe all available media and streaming the media based on the setup commands
rtsp://DevielP:RtspPort/multicast
s i onpociod in o RTSP st sossion However, he servr cod provids clhor media siroams f o clon
rtsp://DevicelP:RispPort/udp/track 'setup other tracks in the RTSP setup session.

;The server has to be able to parser the parameter, track1, upd/track1, and multicast/track1 to response the

tsp://DevielP:RtspPort/multicast/track1 lsetup request

. In : the track number.
rtsp://DevicelP:RtspPort/trackn
\describe all available media and streaming the media based on the setup commands. The track n is only
rtsp://DevicelP:RtspPort/udp/trackn \expected in the RTSP setup session. However, the server could provide other media streams if the client
’ i 'setup other tracks in the RTSP setup session.

tsp://DevielP:RtspPort/multicast/trackn The server has to be able to parser the parameter, trackn, upd/trackn, and multicast/trackn to response the
|setup request

Note: Please make sure your IP and port is changed to your settings before you put the whole

command line into the address bar.

n



Now click “Play” and enter your authentication then you should get your video stream as

shown.
. .
= RTSP auﬂﬁenhcaﬁ'ﬁﬁ ? -gi]
i i N
I Please enter a valid login name and & passwornd .
I User name
Passrond !
| 0K || Comcel |
. — I
A rtsp://192.168.0.100:7070/multicast - VLC media player _@@u
Media Playback Audio Video Tools View Help

rtspa/192.168.0.100: Z07Z0/multicast

@] "
[REOCNC-E ==l
[ rtsp//182.168.0.100-7070/multicast | [1.00x [ 00:00/00:00

:



Apple QuickTime Player

Step 1: Download it from Apple web site http://www.apple.com/quicktime/download/win.html
Step 2: Click on File -> Open URL

it Miew Window Help

[ufin Player

Crl-#n

New dudio Recording Chrfshifesy : = —
Sany Ficturss
Open URL... Ctr+U Hard Candy
B e e oy 3 e Liofys Gate Films
fpen Racert : 16 Blocks
Close Window Chrl+w Warniar 8ros. Pictuies
Evave ChriS ® The} Shaggy 909 B
Save As.., Dm Walt Disney Hictures

Revart o Savad Miami Vice

Expiort,., Ch+E Univarsal Pleturers
Page Setup,.. The Sentine!
Pint... Chrlp 20th Cantury Fox

Exit

The Hills Have Eyes

ox Searchlight Pictures

Mission: Impossible il

‘aramount Pictures

Mozre Movie Trailors @)

+ Record audio
and video

- Encode in
H.264

+ Play movies
Kull scrzen

- Save movies

LG e EXPO

Step 3: Enter URL:
rtsp://<IP Address>

Step 4: Apple QuickTime Player

plays video from ACTi device

x

Enter an Internet URL to open:
frtspr/192.168.1.107 =l

OnickTime Internet 235

1 [192.168.1.2 ] @A [Sewmion streamed by RTRER TEF server | B9
EHEEH :

{ERHHARE . || |
HHE | |

] |

D BE_ |

:


http://www.apple.com/quicktime/download/win.html

File Edit Yiew Window Help

IMPORTANT: RTSP will need account/password authentication. Users may have an
alternative option to carry out the URL command as in the following:
rtsp://username:password@ip:port
When receiving RTP video streams over Internet routers, you have to
enable RTP over TCP in VLC.

Currently, all ACTi products only support one way audio on RTP streaming.

VidBlaster 71 .
. *0‘ ACl onfigurator -
Step 1: Camera setting: o

>> Video Display

1. Log on camera in Web

>> Host Setting

Camera Name Camera-1

Configurator -> Video Setting >> WAN Setting Streaming Method  TCP Only -
" " >> Date Setting B2 Frame Enable []
2. Uncheck "B2 Frame Enable Audioln Disabled ~
-> Video Setting
3. Audio In: Disabled >> Video Adjustment B
" " Resolution  720x480 +
>> Event Frame Rate Mode Constant ~
4. Encoder Type: MJPEG - G B
>> System Info Encoder Type MJPEG ~
»> Firmware Video Quality 50 (1~ 100)

Video Control Port 6001
»> Profile

Video Streaming Port 6002
>> Factory Default

>» Save Reboot

>> Logout

.



Step 2:

File View Modules Video Help

VidBIaster Setting: —Pmgmm T AUdo Unavalable T Streamer
. ’*7',',‘:- [
1. Select "IP Camera" in "vlp
%
camera module X

2. Right click on camera i =

L d R Volume

moduel -> select IP Camera

U R L ~— Camera1l Video Overlay 1 Player 1 Player 2
B

WIDBlaster

' IP Camera Play Stop Trans Play Stop

Camera Video Overlay

er.com

Deinterlace Video

IP Camera

Transition
Aspect Ratio
IP Camera URL

Clear
Remove Module

.



3. Type in " http://ip:port/cgi-bin/system?USER=Admin&PWD=123456&GET_STREAM "

File View Modules Video Help
Program T Audio Unavamape T Streamer
.

-~
4( 0",1

VID

BLASTER

%
<

Enter URL of the IP camera:
http://10.1.1.67/cgi-bin/system?USER=Ad

Cancel

o a— — ayer
=

WIDBlaster |

Play Stop Trans Play Stop Trans

4. You may go to 'Module -> Add -> Camera' to add several cameras.

3 Vrrrfalrrﬁ ..................

File View Modules Video Help
Fogram AUdio Unavainable Streamer

<

L d R Volume

Camera 1 Video Oven ay ayer ayer Z

e szsins WIDBlaster

Play Stop Trans Play Stop Trans

.



Help

AUdio Unavainable
Camera 0
Player

Preview Al -6-

Recorder

-18-
Video Effect 24-
Video Overlay
Video Switcher

-30-
-36-

L d R Volume

Camera Video Over ay ayer ayer Z

: Ba— =
o ot IDBlaster |

Stop Trans Play Stop Trans

o I G
File View Modules Video Help
rogram T AUdio Unavamaple
-0-
&z

-18-
-24-
-30-
-36-

L d R Volume

. - Player 2
IP Camera i ‘

o ¥IDBlaster

Stop Trans Stop Trans

"



How to Get ACTi MPEG4 and RTP/RTSP Specs

Please contact ACTi Sales representatives or sales@acti.com for the detailed specification of
MPEG-4 and RTP/RTSP specifications.

Reference or Specifications

RFC 2326: Real Time Streaming Protocol (RTSP) http://www.ietf.org/rfc/rfc2326.txt

RFC 4571: Framing Real-time Transport Protocol (RTP) and RTP Control Protocol (RTCP)

Packets over Connection-Oriented Transport http://www.ietf.org/rfc/rfc4571.txt
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